/Vulnerability Library

Apache Tika - XXE Injection

CVE-2025-54988
Verified

Description

Apache Tika versions 1.13 through 3.2.1 are vulnerable to XXE via malicious XFA in PDFs, allowing file read and SSRF attacks.

Severity

Critical

CVSS Score

9.8

Exploit Probability

48%

Affected Product

tika

Published Date

April 27, 2026

Template Author

tx1ee, s4e-io

CVE-2025-54988.yaml
9.8Score

CVSS Metrics

CVSS Vector:
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CWE ID:
cwe-611

References

https://lists.apache.org/thread/8xn3rqy6kz5b3l1t83kcofkw0w4mmj1whttps://lists.debian.org/debian-lts-announce/2025/10/msg00030.htmlhttps://nvd.nist.gov/vuln/detail/CVE-2025-54988

Remediation Steps

Upgrade to Apache Tika 3.2.2 or later.